User Tools

Site Tools


vps_-_openbsd

OpenBSD on SDF VPS

First Steps

Root Password

After you have installed and started your OpenBSD VPS, go to the console. This should happen automatically after selecting “r” from the VPS Maintenance Shell. You will then see the beginning of the system loading the bootloader,

We need to interrupt the boot process by hitting the spacebar and then hitting enter after the xenstore-write connected message is shown like so:

[04-Nov-20 21:18:51] Command: r

Connecting to System Console - To return to the menu, press ^]

Parsing config from /usr/pkg/etc/xen/openbsd32
/sbin/ifconfig xvif412i0 up
brconfig bridge0 add xvif412i0
xenstore-write /local/domain/0/backend/vif/412/0/hotplug-status connected
  
boot> 

We are now at the boot loader prompt, next we will boot the kernel into single-user mode like so:

boot> boot -s 

After the kernel loads you should be presented with a shell prompt similar to this:

root on sd0a (1318956d982f595b.a) swap on sd0b dump on sd0b
Enter pathname of shell or RETURN for sh:

#

Next is ensuring our filesystem is clean and mounting it in read-write mode:

# fsck -p / && mount -uw /                                              
/dev/sd0a (1318956d982f595b.a): file system is clean; not checking
# 

And finally you can update the root password via the passwd(1) command. Once the desired root password is set you then reboot the VM and allow it to auto-load into a regular multi-user environment:

# passwd
Changing password for root.
New password:
Retype new password:
# reboot

User Accounts

It is also a good habit to create a regular user account for working, using “su” to obtain root privileges as needed. To create a regular user account which is part of the administrative “wheel” group:

useradd -m -G wheel username

Then immediately set its password with:

passwd username

This user will be in the “wheel” group and will be able to perform administrative tasks by runing “su” to obtain superuser privileges using the root password.

For doas copy over the example and then edit

cp /etc/example/doas.conf /etc && vi /etc/doas.conf

Networking

As root edit /etc/hostname.if (should be xnf0)

vi /etc/hostname.xnf0

remove the inet autoconf and replace it with inet ip 255.255.255.0

As root edit /etc/mygate

vi /etc/mygate 

Add in the gateway ip from welcome email

As root edit /etc/myname

vi /etc/myname 

Add in a hostname that makes sense

As root type in /etc/netstart

sh /etc/netstart

Should now see your ip listed when doing ifconfig

Now run sysupgrade twice to get the latest version

References

  • OpenBSD afterboot(8) man page is a great starting point for configuring you new system: afterboot(8)
  • doas(1) is included with the base OpenBSD system and performs a similar role as the popular sudo utility: doas(1)

$Id: VPS_NetBSD.html,v 1.23 2018/02/22 15:12:01 slugmax Exp $

vps_-_openbsd.txt · Last modified: 2023/06/11 22:03 by cpet